summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-02-01 14:00:39 +0100
committerLeo Famulari <leo@famulari.name>2020-02-02 16:11:34 -0500
commit7b2ba609c3663b77ede10199c9d49855ee1ab0b4 (patch)
tree175f79d243e31e6c71744fa12bf7ccca3f411c03 /gnu/packages/game-development.scm
parent451e1075f0aaca1a8234d34efc017284406fe375 (diff)
downloadguix-7b2ba609c3663b77ede10199c9d49855ee1ab0b4.tar.gz
gnu: godot: Add zenity for showing alerts.
* gnu/packages/game-development.scm (godot)[inputs]: Add zenity.
[arguments]: Wrap godot to look for it in the store.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index c9a8b922b4..6fa4fed74f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1599,6 +1599,10 @@ games.")
                      (rename-file "godot.x11.tools.64" "godot")
                      (rename-file "godot.x11.tools.32" "godot"))
                  (install-file "godot" bin))
+               ;; Tell Godot where to find zenity for OS.alert().
+               (wrap-program (string-append bin "/godot")
+                 `("PATH" ":" prefix
+                   (,(string-append (assoc-ref %build-inputs "zenity") "/bin"))))
                #t)))
          (add-after 'install 'install-godot-desktop
            (lambda* (#:key outputs #:allow-other-keys)
@@ -1642,6 +1646,7 @@ games.")
               ("pcre2" ,pcre2)
               ("pulseaudio" ,pulseaudio)
               ("wslay" ,wslay)
+              ("zenity" ,zenity)
               ("zstd" ,zstd "lib")))
     (home-page "https://godotengine.org/")
     (synopsis "Advanced 2D and 3D game engine")