summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-08-14 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-14 02:00:56 +0200
commit466021fb90d88ef9cecbb8cd491e7991bae1b6e5 (patch)
tree111e0b8427b01d6537ba0a1e5446cd2a2ed0e6e2 /gnu/packages/game-development.scm
parentee2657a018b5972ec41280abb215c6ba45c0a6fc (diff)
downloadguix-466021fb90d88ef9cecbb8cd491e7991bae1b6e5.tar.gz
gnu: ioquake3: Use G-expressions.
* gnu/packages/game-development.scm (ioquake3)[arguments]:
Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index e4a7ce1ae1..774564ed2a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2165,23 +2165,25 @@ of the others")
        (list which ; Else SDL_version.h won't be found.
              pkg-config))
       (arguments
-       '(#:tests? #f                    ; No tests.
-         #:make-flags '("CC=gcc"
+       (list
+        #:tests? #f                     ; no tests
+        #:make-flags
+        #~(list "CC=gcc"
+                "USE_INTERNAL_LIBS=0"
+                "USE_FREETYPE=1"
+                "USE_RENDERER_DLOPEN=0"
+                "USE_OPENAL_DLOPEN=0"
+                "USE_CURL_DLOPEN=0")
+        #:phases
+        #~(modify-phases %standard-phases
+            (delete 'configure)         ; no configure-script
+            (replace 'install
+              (lambda* (#:key outputs #:allow-other-keys)
+                (invoke "make" "copyfiles" "CC=gcc"
                         "USE_INTERNAL_LIBS=0"
-                        "USE_FREETYPE=1"
-                        "USE_RENDERER_DLOPEN=0"
-                        "USE_OPENAL_DLOPEN=0"
-                        "USE_CURL_DLOPEN=0")
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'configure)
-           (replace 'install
-             (lambda* (#:key outputs #:allow-other-keys)
-               (invoke "make" "copyfiles" "CC=gcc"
-                        "USE_INTERNAL_LIBS=0"
-                       (string-append "COPYDIR="
-                                      (assoc-ref outputs "out")
-                                      "/bin")))))))
+                        (string-append "COPYDIR="
+                                       (assoc-ref outputs "out")
+                                       "/bin")))))))
       (home-page "https://ioquake3.org/")
       (synopsis "FPS game engine based on Quake 3")
       (description "ioquake3 is a free software first person shooter engine