summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-11 13:18:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-11 13:18:27 +0100
commit902068b43664b862dfcbb9172f41778d576e3ae0 (patch)
treea616e583318db52616ee735368bac19311f8f979 /gnu/packages/game-development.scm
parent9066424778d2b7b7b73968a91e64ce2b53a163fe (diff)
downloadguix-902068b43664b862dfcbb9172f41778d576e3ae0.tar.gz
gnu: tiled: Fetch sources from git.
* gnu/packages/game-development.scm (tiled)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index da1675820b..1f73025db7 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -399,13 +399,14 @@ support.")
     (name "tiled")
     (version "1.2.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/bjorn/tiled/archive/v"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/bjorn/tiled.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "13dlf5kzvhhjkhy19118x3diakmraz4m9kxrsdam8dms6xivb6lp"))))
+                "1rra48hlkcgqxwxi802fb182p1q0723c9hhfvkd5inz9467idd4c"))))
     (build-system gnu-build-system)
     (inputs
      `(("qtbase" ,qtbase)