summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-01 16:26:21 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-01 16:26:21 +0100
commitc4f197d5e4a475597e0521f9bda8d0269a37363e (patch)
tree57dc85e21807e22113f91ed073bc3599a00c6eec /gnu/packages/game-development.scm
parent3dd74c8dc5192c3ffae5c991aa63aa6154a1bc7d (diff)
downloadguix-c4f197d5e4a475597e0521f9bda8d0269a37363e.tar.gz
gnu: ode: Update to 0.16.1.
* gnu/packages/game-development.scm (ode): Update to 0.16.1.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 05e026a846..262633760b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2046,14 +2046,14 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
 (define-public ode
   (package
     (name "ode")
-    (version "0.16")
+    (version "0.16.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://bitbucket.org/odedevs/ode/downloads/"
                            "ode-" version ".tar.gz"))
        (sha256
-        (base32 "09xzrarxwxcf6rdv5jsjfjh454jnn29dpcw3wh6ic50kkipvg8sb"))
+        (base32 "1flfdqgdbcn1bx8nrrd4qnp6cvsxrhvk8cdg7vaq2dzkh6nsqa5j"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -2061,7 +2061,8 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
            #t))))
     (build-system cmake-build-system)
     (arguments
-     ;; Tests fail on all systems but x86_64.
+     ;; Tests fail on all systems but x86_64.  This is fixed upstream and can
+     ;; be removed in 0.16.2+.
      `(#:tests? ,(string-prefix? "x86_64-"
                                  (or (%current-target-system)
                                      (%current-system)))