summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-01-09 08:55:03 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-02-07 15:17:55 +0100
commiteaa998577bba954b121f296f84b8b65e5ca2ec04 (patch)
tree018b641df1da4e81e720b893a6963887c84c49e3 /gnu/packages/game-development.scm
parentb4d71a62ade12df6a28487ff308fb3fa0ef1fcbb (diff)
downloadguix-eaa998577bba954b121f296f84b8b65e5ca2ec04.tar.gz
gnu: python2-renpy: Update to 7.4.0.
* gnu/packages/game-development.scm (python2-renpy): Update to 7.4.0.
(inputs): Move python2-pygame...
(propagated-inputs): ... to here.  Add python2-future.
(#:phases)[install]: Infer python version from input.
* gnu/packages/patches/renpy-use-system-fribidi.patch: Update to renpy 7.4.0.

python2-renpy: propagate python inputs
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index f1818e54e8..d8ea29b408 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1141,13 +1141,13 @@ developed mainly for Ren'py.")
 (define-public python2-renpy
   (package
     (name "python2-renpy")
-    (version "7.3.5")
+    (version "7.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.renpy.org/dl/" version
                            "/renpy-" version "-source.tar.bz2"))
-       (sha256 (base32 "1anr5cfbvbsbik4v4rvrkdkciwhg700k4lydfbs4n85raimz9mw4"))
+       (sha256 (base32 "0av3mbh54xh6i3rvf60x5hbsjcfpzgia2j958mhyc5826zjxzfpg"))
        (modules '((guix build utils)))
        (patches
         (search-patches
@@ -1204,8 +1204,8 @@ developed mainly for Ren'py.")
              ;; (both source and compiled) in the same directory.
              (let* ((out (assoc-ref outputs "out"))
                     (site (string-append "/lib/python"
-                                         ,(version-major+minor
-                                           (package-version python-2))
+                                         (python-version
+                                          (assoc-ref inputs "python"))
                                          "/site-packages")))
                (with-directory-excursion "module"
                  (apply (assoc-ref %standard-phases 'install) args))
@@ -1218,9 +1218,11 @@ developed mainly for Ren'py.")
        ("fribidi" ,fribidi)
        ("glew" ,glew)
        ("libpng" ,libpng)
-       ("python2-pygame" ,python2-pygame-sdl2)
        ("sdl-union"
         ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+    (propagated-inputs
+     `(("python2-future" ,python2-future)
+       ("python2-pygame" ,python2-pygame-sdl2)))
     (native-inputs
      `(("python2-cython" ,python2-cython)
        ("xdg-utils" ,xdg-utils)))
@@ -1234,7 +1236,6 @@ modules of Ren'py.")
   (package
     (inherit python2-renpy)
     (name "renpy")
-    (version "7.3.5")
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ; see python2-renpy