summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-26 00:06:49 +0100
committerMarius Bakke <marius@gnu.org>2021-12-26 00:58:27 +0100
commit3776668c5ef4123e8f79915d905d3d90eab6ab05 (patch)
tree3ca3f18700562480bfa602dce588bda0e25aaa5e /gnu/packages/games.scm
parentd9aa923dfd1ec95332cabd68c7e73aec91bb2127 (diff)
downloadguix-3776668c5ef4123e8f79915d905d3d90eab6ab05.tar.gz
gnu: fifengine: Simplify inputs.
* gnu/packages/games.scm (fifengine)[native-inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d59d8482eb..781074ed7c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3767,6 +3767,8 @@ Widgets, and allows users to create more.")
                      (chdir #$(string-append "../" (package-name this-package)
                                              "-" (package-version this-package)))
                      (invoke "python3" "run_tests.py" "-a")))))))
+    (native-inputs
+     (list python swig xorg-server-for-tests))
     (inputs
      (list sdl2
            sdl2-image
@@ -3780,10 +3782,6 @@ Widgets, and allows users to create more.")
            fifechan
            swig
            python))
-    (native-inputs
-     `(("python" ,python)
-       ("swig" ,swig)
-       ("xvfb" ,xorg-server)))
     (propagated-inputs
      (list python-future))
     (home-page "https://www.fifengine.net/")