summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-01-05 19:16:11 +0000
committerLeo Famulari <leo@famulari.name>2022-01-05 15:50:59 -0500
commit707acc4cfb5e965fe471cd77220c16e25f986a5c (patch)
treea34ed05d5241b1876fbd0ffd7ccfcbe3f1d287f7 /gnu/packages/games.scm
parent0fea9aec59f8f328c269d585d849a8f954e39aae (diff)
downloadguix-707acc4cfb5e965fe471cd77220c16e25f986a5c.tar.gz
gnu: supertux: Update to 0.6.3.
* gnu/packages/games.scm (supertux): Update to 0.6.3.
[inputs] Sort list and add glm.
* gnu/packages/patches/supertux-unbundle-squirrel.patch: Adjust patch to
apply with upstream changes.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d884df588a..bfd566aac0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5442,7 +5442,7 @@ with the \"Stamp\" tool within Tux Paint.")
 (define-public supertux
   (package
    (name "supertux")
-   (version "0.6.2")
+   (version "0.6.3")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/SuperTux/supertux/"
@@ -5451,7 +5451,7 @@ with the \"Stamp\" tool within Tux Paint.")
             (file-name (string-append name "-" version ".tar.gz"))
             (sha256
              (base32
-              "167m3z4m8n76dvbv42m1fnvabpbpsxvr28zk9641916jl9pfba96"))
+              "1xkr3ka2sxp5s0spp84iv294i29s1vxqzazb6kmjc0n415h0x57p"))
             (patches
              (search-patches "supertux-unbundle-squirrel.patch"))))
    (arguments
@@ -5471,18 +5471,19 @@ with the \"Stamp\" tool within Tux Paint.")
                  (string-append "${SQUIRREL_PREFIX}/include/squirrel"))))
             #t)))))
    (build-system cmake-build-system)
-   (inputs (list sdl2
-                 sdl2-image
-                 sdl2-mixer
-                 openal
-                 mesa
+   (inputs (list boost
+                 curl
+                 freetype
                  glew
-                 libvorbis
+                 glm
                  libogg
+                 libvorbis
+                 mesa
+                 openal
                  physfs
-                 curl
-                 boost
-                 freetype
+                 sdl2
+                 sdl2-image
+                 sdl2-mixer
                  squirrel))
    (native-inputs
     (list pkg-config))