summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-06-18 15:33:59 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-22 10:27:21 +0200
commitb6fc274637c69929e7811b40bf9b99d3e8df8360 (patch)
treeedc5d887f02be9f75eadeea8a098e3cc59eb2b1e /gnu/packages/games.scm
parent44bccf414b6ba285035fa3e22512b4b99b853776 (diff)
downloadguix-b6fc274637c69929e7811b40bf9b99d3e8df8360.tar.gz
gnu: widelands: Update to 1.0.
* gnu/packages/games.scm (widelands): Update to 1.0.
[source]: Download from github as there is no tarball for v1.0 on their
website.
[inputs]: Add curl.
* gnu/packages/patches/widelands-system-wide_minizip.patch: Adjust for
1.0. CmakeLists.txt now already defines CMAKE_MODULE_PATH, so I've moved
FindMinizip.cmake to this path.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fca25294db..9944c0dcc6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5215,15 +5215,16 @@ tactics.")
 (define-public widelands
   (package
     (name "widelands")
-    (version "21")
+    (version "1.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://launchpad.net/widelands/"
-                           "build" version "/build" version "/+download/"
-                           "widelands-build" version "-source.tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/widelands/widelands")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0mz3jily0w1zxxqbnkqrp6hl88xhrwzbil9crq7gpcwidx60w7k0"))
+        (base32 "1hw51binnbia15mj1gzx1cbk3cw9r91sisqci2qzcy4ahxiadnw0"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -5263,7 +5264,8 @@ tactics.")
      `(("gettext" ,gettext-minimal)
        ("python" ,python-wrapper)))
     (inputs
-     `(("boost" ,boost)
+     `(("curl" ,curl)
+       ("boost" ,boost)
        ("glew" ,glew)
        ("icu4c" ,icu4c)
        ("libpng" ,libpng)