summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-30 18:58:57 +0200
committerMarius Bakke <marius@gnu.org>2022-08-30 18:58:57 +0200
commit827b4117daa7a7f5cdd84e0211c3acb778e9246b (patch)
tree6ca042081f2e98c599bb3121af025ca35bdc0431 /gnu/packages/games.scm
parent1cf37370937665f21b4fb01daeffbf90c671611e (diff)
parentdb2444ad824ab529fd9e850dbae42359009ac4a2 (diff)
downloadguix-827b4117daa7a7f5cdd84e0211c3acb778e9246b.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm142
1 files changed, 0 insertions, 142 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index aa2e4e04b0..2b540ee59b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7622,148 +7622,6 @@ entirely config file, savegame, netplay and demo compatible with the
 original.")
     (home-page "https://www.chocolate-doom.org/wiki/index.php/Crispy_Doom")))
 
-(define shlomif-cmake-modules
-  (origin
-    (method url-fetch)
-    (uri (string-append
-          "https://raw.githubusercontent.com/shlomif/shlomif-cmake-modules/"
-          "89f05caf86078f783873975525230cf4fecede8a"
-          "/shlomif-cmake-modules/Shlomif_Common.cmake"))
-    (sha256
-     (base32 "05xdikw5ln0yh8p5chsmd8qnndmxg5b5vjlfpdqrjcb1ncqzywkc"))))
-
-(define-public rinutils
-  (package
-    (name "rinutils")
-    (version "0.10.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/shlomif/rinutils")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0r90kncf6mvyklifpdsnm50iya7w2951nz35nlgndmqnr82gvdwf"))))
-    (build-system cmake-build-system)
-    (arguments
-     (list #:phases
-           #~(modify-phases %standard-phases
-               (add-after 'unpack 'copy-cmake-modules
-                 (lambda _
-                   (copy-file #$shlomif-cmake-modules
-                              (string-append "cmake/"
-                                             (strip-store-file-name
-                                              #$shlomif-cmake-modules)))))
-               (replace 'check
-                 (lambda* (#:key tests? #:allow-other-keys)
-                   (when tests?
-                     (with-directory-excursion "../source"
-                       (setenv "FCS_TEST_BUILD" "1")
-                       (setenv "RINUTILS_TEST_BUILD" "1")
-                       ;; TODO: Run tests after setting RINUTILS_TEST_TIDY to `1',
-                       ;; which requires tidy-all.
-                       ;; (setenv "RINUTILS_TEST_TIDY" "1")
-                       (invoke "perl"
-                               "CI-testing/continuous-integration-testing.pl"))))))))
-    (native-inputs
-     (list perl
-           ;; The following are needed only for tests.
-           perl-class-xsaccessor
-           perl-file-find-object
-           perl-io-all
-           perl-test-differences
-           perl-test-runvalgrind
-           pkg-config))
-    (inputs
-     (list cmocka
-           perl-env-path
-           perl-inline
-           perl-inline-c
-           perl-string-shellquote
-           perl-test-trailingspace
-           perl-file-find-object-rule
-           perl-text-glob
-           perl-number-compare
-           perl-moo))
-    (home-page "https://www.shlomifish.org/open-source/projects/")
-    (synopsis "C11 / gnu11 utilities C library")
-    (description "This package provides C11 / gnu11 utilities C library")
-    (license license:expat)))
-
-(define-public fortune-mod
-  (package
-    (name "fortune-mod")
-    (version "3.14.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/shlomif/fortune-mod")
-             (commit (string-append "fortune-mod-" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1f2zif3s6vddbhph4jr1cymdsn7gagg59grrxs0yap6myqmy8shg"))))
-    (build-system cmake-build-system)
-    (arguments
-     (list #:configure-flags
-           #~(let ((fortunes (string-append #$output "/share/fortunes")))
-               (list (string-append "-DLOCALDIR=" fortunes)
-                     (string-append "-DLOCALODIR=" fortunes "/off")
-                     (string-append "-DCOOKIEDIR=" fortunes)
-                     (string-append "-DOCOOKIEDIR=" fortunes "/off")))
-           #:test-target "check"
-           #:phases
-           #~(modify-phases %standard-phases
-               (add-after 'unpack 'enter-build-directory
-                 (lambda _
-                   (chdir "fortune-mod")))
-               (add-after 'enter-build-directory 'symlink-rinutils
-                 (lambda _
-                   (mkdir-p "rinutils")
-                   (symlink #$(this-package-native-input "rinutils")
-                            "rinutils/rinutils")))
-               (add-after 'enter-build-directory 'copy-cmake-modules
-                 (lambda _
-                   (copy-file #$shlomif-cmake-modules
-                              (string-append "cmake/"
-                                             (strip-store-file-name
-                                              #$shlomif-cmake-modules)))))
-               (add-after 'enter-build-directory 'delete-failing-test
-                 (lambda _
-                   ;; TODO: Valgrind tests fail for some reason.  Similar issue?
-                   ;; https://github.com/shlomif/fortune-mod/issues/21
-                   (delete-file "tests/data/valgrind.t")
-                   (with-output-to-file "tests/scripts/split-valgrind.pl"
-                     (const #t))))
-               (add-after 'install 'fix-install-directory
-                 ;; Move fortune from "games/" to "bin/" and remove the
-                 ;; former.  This is easier than patching CMakeLists.txt
-                 ;; since the tests hard-code the location as well.
-                 (lambda _
-                   (with-directory-excursion #$output
-                     (rename-file "games/fortune" "bin/fortune")
-                     (rmdir "games")))))))
-    (inputs (list recode))
-    (native-inputs
-     (list perl
-           ;; For generating the documentation.
-           docbook-xml-5
-           docbook-xsl
-           perl-app-xml-docbook-builder
-           ;; The following are only needed for tests.
-           perl-file-find-object
-           perl-test-differences
-           perl-class-xsaccessor
-           perl-io-all
-           perl-test-runvalgrind
-           rinutils))
-    (home-page "https://www.shlomifish.org/open-source/projects/fortune-mod/")
-    (synopsis "The Fortune Cookie program from BSD games")
-    (description "Fortune is a command-line utility which displays a random
-quotation from a collection of quotes.")
-    (license license:bsd-4)))
-
 (define xonotic-data
   (package
     (name "xonotic-data")