summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-23 19:06:47 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-23 19:06:47 +0100
commitef060487a21833f097485b583fd7f5813109444e (patch)
tree67d57c1ead734f41d367d2d28074f2e78febae0d /gnu/packages/games.scm
parenta3c26687885305a6a9fda3aef3c66a9fcc962e67 (diff)
downloadguix-ef060487a21833f097485b583fd7f5813109444e.tar.gz
gnu: naev: Update to 0.10.0.
* gnu/packages/games.scm (naev): Update to 0.10.0.
[inputs]: Add ENET, PCRE2.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7dd73dcb4a..19c689dee1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7930,7 +7930,7 @@ ncurses for text display.")
 (define-public naev
   (package
     (name "naev")
-    (version "0.9.4")
+    (version "0.10.0")
     (source
      (origin
        (method git-fetch)
@@ -7940,7 +7940,7 @@ ncurses for text display.")
              (recursive? #t))) ; for game data
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0isswidhxhs2q5c4cxryjr8y8ibfxckpfyccly3b4lg1nxvm5gjv"))))
+        (base32 "183dbi4a91xggxm1rmn7vr8rq519yz7b3zhrd03azsg6fxylv9wn"))))
     (build-system meson-build-system)
     (arguments
      ;; XXX: Do not add debugging symbols, which cause the build to fail.
@@ -7949,7 +7949,8 @@ ncurses for text display.")
     (native-inputs
      (list gettext-minimal pkg-config))
     (inputs
-     (list freetype
+     (list enet
+           freetype
            glpk
            libpng
            libunibreak
@@ -7959,6 +7960,7 @@ ncurses for text display.")
            luajit
            openal
            openblas
+           pcre2
            physfs
            python
            python-pyyaml