summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-06-02 13:29:52 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-05 00:05:38 +0200
commit698bd29799089c84bc2aa2c5f40e61eba83dd0b8 (patch)
tree1ab84a615f541fba557bacf842a77d7ef2650c5f /gnu/packages/games.scm
parent1713c37f835a0566a47d76d2379b2d0b12c0b548 (diff)
downloadguix-698bd29799089c84bc2aa2c5f40e61eba83dd0b8.tar.gz
gnu: Use full SHA1 commit ids.
* gnu/packages/bioinformatics.scm (pbtranscript-tofu, mosaik,
  smithlab-cpp, piranha): Use full SHA1 commit ids.
* gnu/packages/ci.scm (hydra): Likewise.
* gnu/packages/compression.scm (sfarkxtc): Likewise.
* gnu/packages/emacs.scm (emacs-ob-ipython): Likewise.
* gnu/packages/games.scm (mars, emulation-station): Likewise.
* gnu/packages/gnunet.scm (guile-gnunet): Likewise.
* gnu/packages/music.scm (non-sequencer): Likewise.
* gnu/packages/version-control.scm (git-flow, git-test-sequence): Likewise.
* gnu/packages/xorg.scm (xf86-video-intel): Likewise.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm59
1 files changed, 30 insertions, 29 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e552d09efa..368f09632c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -590,11 +590,11 @@ for common mesh file formats, and collision detection.")
   ;; The latest release on SourceForge relies on an unreleased version of SFML
   ;; with a different API, so we take the latest version from the official
   ;; repository on Github.
-  (let ((commit   "c855d04409")
+  (let ((commit   "c855d044094a1d92317e38935d81ba938946132e")
         (revision "1"))
     (package
       (name "mars")
-      (version (string-append "0.7.5." revision "." commit ))
+      (version (string-append "0.7.5." revision "." (string-take commit 7) ))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -1833,36 +1833,37 @@ emulation community.  It provides highly accurate emulation.")
     (license license:gpl2+)))
 
 (define-public emulation-station
-  (package
-    (name "emulation-station")
-    (version "2.0.1")
-    (source (origin
-              (method git-fetch) ; no tarball available
-              (uri (git-reference
-                    (url "https://github.com/Aloshi/EmulationStation.git")
-                    (commit "646bede"))) ; no version tag
-              (sha256
-               (base32
-                "0cm0sq2wri2l9cvab1l0g02za59q7klj0h3p028vr96n6njj4w9v"))))
-    (build-system cmake-build-system)
-    (arguments
-     '(#:tests? #f)) ; no tests
-    (inputs
-     `(("alsa-lib" ,alsa-lib)
-       ("boost" ,boost)
-       ("curl" ,curl)
-       ("eigin" ,eigen)
-       ("freeimage" ,freeimage)
-       ("freetype" ,freetype)
-       ("mesa" ,mesa)
-       ("sdl2" ,sdl2)))
-    (synopsis "Video game console emulator front-end")
-    (description "EmulationStation provides a graphical front-end to a large
+  (let ((commit "646bede3d9ec0acf0ae378415edac136774a66c5"))
+    (package
+      (name "emulation-station")
+      (version "2.0.1")
+      (source (origin
+                (method git-fetch) ; no tarball available
+                (uri (git-reference
+                      (url "https://github.com/Aloshi/EmulationStation.git")
+                      (commit commit))) ; no version tag
+                (sha256
+                 (base32
+                  "0cm0sq2wri2l9cvab1l0g02za59q7klj0h3p028vr96n6njj4w9v"))))
+      (build-system cmake-build-system)
+      (arguments
+       '(#:tests? #f)) ; no tests
+      (inputs
+       `(("alsa-lib" ,alsa-lib)
+         ("boost" ,boost)
+         ("curl" ,curl)
+         ("eigin" ,eigen)
+         ("freeimage" ,freeimage)
+         ("freetype" ,freetype)
+         ("mesa" ,mesa)
+         ("sdl2" ,sdl2)))
+      (synopsis "Video game console emulator front-end")
+      (description "EmulationStation provides a graphical front-end to a large
 number of video game console emulators.  It features an interface that is
 usable with any game controller that has at least 4 buttons, theming support,
 and a game metadata scraper.")
-    (home-page "http://www.emulationstation.org")
-    (license license:expat)))
+      (home-page "http://www.emulationstation.org")
+      (license license:expat))))
 
 (define openttd-engine
   (package