summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-21 01:47:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-21 01:47:05 +0200
commit027285691ae2ac1806cbf19bbdcf9b6e2dd451ff (patch)
treea12405239be22d0a44a97e1cf97423cc16f7c86a /gnu/packages/games.scm
parentfb5296605e84a09764c7428e778c54af5033b722 (diff)
downloadguix-027285691ae2ac1806cbf19bbdcf9b6e2dd451ff.tar.gz
gnu: xmoto: Unbundle ODE and libccd.
* gnu/packages/games.scm (xmoto): Unbundle ODE and libccd.
[inputs]: Add ode.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d01d3fc8d9..76ddbabc2e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10438,14 +10438,11 @@ This package is part of the KDE games module.")
          (modules '((guix build utils)
                     (ice-9 ftw)
                     (srfi srfi-1)))
-         ;; XXX: Remove some bundled libraries.  Guix provides
-         ;; Chipmunk, but it appears to be incompatible with the
-         ;; (older) one bundled. Likewise, Guix provides ODE, but
-         ;; using it induces rendering issues.  Eventually, libccd is
-         ;; required to compile built-in ODE.
+         ;; XXX: Remove some bundled libraries.  Guix provides Chipmunk, but
+         ;; it appears to be incompatible with the (older) one bundled.
          (snippet
           `(begin
-             (let ((keep '("chipmunk" "glad" "libccd" "md5sum" "ode")))
+             (let ((keep '("chipmunk" "glad" "md5sum")))
                (with-directory-excursion "vendor"
                  (for-each delete-file-recursively
                            (lset-difference string=?
@@ -10510,6 +10507,7 @@ This package is part of the KDE games module.")
          ("libxdg-basedir" ,libxdg-basedir)
          ("libxml2" ,libxml2)
          ("lua" ,lua-5.1)
+         ("ode" ,ode)
          ("sdl" ,(sdl-union (list sdl sdl-mixer sdl-net sdl-ttf)))
          ("sqlite" ,sqlite)
          ("zlib" ,zlib)))