summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-19 18:00:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-19 18:00:41 +0200
commit57d87f435fcb05a8e44a6d0545d0212429826bd0 (patch)
tree930059488e65f6f747ca4b3aafa3a5ddbf5c0821 /gnu/packages/games.scm
parentb16e08279938fae329e62154da749860bdccef04 (diff)
downloadguix-57d87f435fcb05a8e44a6d0545d0212429826bd0.tar.gz
gnu: supertux: Adjust for recent GCC and Boost.
* gnu/packages/patches/supertux-fix-build-with-gcc5.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/games.scm (supertux)[source](patches): Remove.
[arguments]: Adjust <#:configure-flags>.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8e9db1412a..1088d2ff4b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3519,12 +3519,12 @@ with the \"Stamp\" tool within Tux Paint.")
              (base32
               "1h1s4abirkdv4ag22zvyk6zkk64skqbjmcnnba67ps4hdzxfbhy4"))
             (patches
-             (search-patches "supertux-fix-build-with-gcc5.patch"
-                             "supertux-unbundle-squirrel.patch"))))
+             (search-patches "supertux-unbundle-squirrel.patch"))))
    (arguments
     '(#:tests? #f
       #:configure-flags '("-DINSTALL_SUBDIR_BIN=bin"
-                          "-DENABLE_BOOST_STATIC_LIBS=OFF"
+                          ;; XXX: Work around <https://bugs.gnu.org/36721>.
+                          "-DBoost_NO_BOOST_CMAKE=ON"
                           "-DUSE_SYSTEM_PHYSFS=ON")
       #:phases
       (modify-phases %standard-phases