summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-19 23:01:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-20 10:02:48 +0200
commit6484b09141ee543174a7d11da23c43b58b3f3aaf (patch)
treeac2d2acc3a2a2b759c1134582e9a385b0cec0680 /gnu/packages/games.scm
parent8840971767b9cfa78e204a607addcff2292a5026 (diff)
downloadguix-6484b09141ee543174a7d11da23c43b58b3f3aaf.tar.gz
gnu: laby: Don't use unstable tarball.
* gnu/packages/games.scm (laby)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 893fb7eae4..efe8a6af0c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3788,13 +3788,14 @@ Linux / Mac OS X servers, and an auto mapper with a VT100 map display.")
     (name "laby")
     (version "0.6.4")
     (source
-     (origin (method url-fetch)
-             (uri (string-append
-                   "https://github.com/sgimenez/laby/archive/"
-                   "laby-" version ".tar.gz"))
+     (origin (method git-fetch)
+             (uri (git-reference
+                    (url "https://github.com/sgimenez/laby.git")
+                    (commit (string-append name "-" version))))
+             (file-name (git-file-name name version))
              (sha256
               (base32
-               "0gyrfa95l1qka7gbjf7l6mk7mbfvph00l0c995ia272qdw7rjhyf"))
+               "12fq9hhrxpzgfinmj9ra9ckss9yficwdlrmgjvvsq7agvh3sgyl1"))
              (patches (search-patches "laby-make-install.patch"))))
     (build-system gnu-build-system)
     (inputs