summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-03-01 20:30:28 +0100
committerLeo Famulari <leo@famulari.name>2023-03-03 20:48:59 -0500
commit1b07f397dc17e31ad55b80a4efd34fdcb5b3c690 (patch)
tree459f15162b4fa65253f7cb63969c4c5fca99aac6 /gnu/packages/games.scm
parentd762991620b68db70c6c818050d825d90d2b54ec (diff)
downloadguix-1b07f397dc17e31ad55b80a4efd34fdcb5b3c690.tar.gz
gnu: widelands: Update to 1.1.
* gnu/packages/games.scm (widelands): Update to 1.1.
[source]: Remove obsolete patches.
[native-inputs]: Add pkg-config.
[inputs]: Add asio.
* gnu/packages/patches/widelands-add-missing-map-include.patch,
gnu/packages/patches/widelands-system-wide_minizip.patch: Delete
files.
* gnu/local.mk (dist_patch_DATA): Remove them.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5783c1d1b..605a23a405 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5355,7 +5355,7 @@ tactics.")
 (define-public widelands
   (package
     (name "widelands")
-    (version "1.0")
+    (version "1.1")
     (source
      (origin
        (method git-fetch)
@@ -5364,17 +5364,12 @@ tactics.")
               (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1hw51binnbia15mj1gzx1cbk3cw9r91sisqci2qzcy4ahxiadnw0"))
+        (base32 "07wbalwdmml9vdh9nh50svnsw4sdj9nnp32azbss8vzq5mxmzvbx"))
        (modules '((guix build utils)))
        (snippet
         '(begin
            (delete-file-recursively "src/third_party/minizip")
-           #t))
-       (patches
-        ;; Use system Minizip.  Patch is provided by Debian, and discussed
-        ;; upstream at <https://github.com/widelands/widelands/issues/399>.
-        (search-patches "widelands-system-wide_minizip.patch"
-                        "widelands-add-missing-map-include.patch"))))
+           #t))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags
@@ -5403,9 +5398,11 @@ tactics.")
              #t)))))
     (native-inputs
      `(("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)))
     (inputs
-     `(("curl" ,curl)
+     `(("asio" ,asio)
+       ("curl" ,curl)
        ("boost" ,boost)
        ("glew" ,glew)
        ("icu4c" ,icu4c)