summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-10-05 14:39:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-10-05 14:39:53 +0300
commit3699ed63501a28629956ca60e198f5fafa57ad4e (patch)
treed6b7564ee80ddd06c94ae682ec4aeb3603c94da3 /gnu/packages/games.scm
parent31c81fefff7c3290f0a6f0b8d2c2d3855a7ba196 (diff)
downloadguix-3699ed63501a28629956ca60e198f5fafa57ad4e.tar.gz
gnu: astromance: Correctly link to game data.
Fixes <http://issues.guix.gnu.org/43797>.

* gnu/packages/games.scm (astromance)[arguments]: Adjust configure-flags
to point the DATADIR to a directory in the output.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 28c1492b26..729078dc69 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -429,7 +429,9 @@ physics settings to tweak as well.")
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ;no test
-       #:configure-flags '("-DDATADIR=share/astromenace")
+       #:configure-flags (list (string-append "-DDATADIR="
+                                              (assoc-ref %outputs "out")
+                                              "/share/astromenace"))
        #:phases
        (modify-phases %standard-phases
          (replace 'install