summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-04 15:44:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-05 03:54:03 +0100
commitf7e6e936624c495cf138d7fc03850a2e7f2b9467 (patch)
tree5bc35afaaa00a7fecceb5f4ef7af1858b77d56ee /gnu/packages/games.scm
parent8646f1f7a53d28f305f30420ad23b670159c53a9 (diff)
downloadguix-f7e6e936624c495cf138d7fc03850a2e7f2b9467.tar.gz
gnu: rinutils: Respect #:tests?
* gnu/packages/games.scm (rinutils)[arguments]: Respect #:tests? in 'check.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5896fa4333..d884df588a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7530,15 +7530,16 @@ original.")
                                              (strip-store-file-name
                                               #$shlomif-cmake-modules)))))
                (replace 'check
-                 (lambda _
-                   (with-directory-excursion "../source"
-                     (setenv "FCS_TEST_BUILD" "1")
-                     (setenv "RINUTILS_TEST_BUILD" "1")
-                     ;; TODO: Run tests after setting RINUTILS_TEST_TIDY to `1',
-                     ;; which requires tidy-all.
-                     ;; (setenv "RINUTILS_TEST_TIDY" "1")
-                     (invoke "perl"
-                             "CI-testing/continuous-integration-testing.pl")))))))
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (with-directory-excursion "../source"
+                       (setenv "FCS_TEST_BUILD" "1")
+                       (setenv "RINUTILS_TEST_BUILD" "1")
+                       ;; TODO: Run tests after setting RINUTILS_TEST_TIDY to `1',
+                       ;; which requires tidy-all.
+                       ;; (setenv "RINUTILS_TEST_TIDY" "1")
+                       (invoke "perl"
+                               "CI-testing/continuous-integration-testing.pl"))))))))
     (native-inputs
      (list perl
            ;; The following are needed only for tests.