summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorphodina <phodina@protonmail.com>2021-11-08 18:45:09 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-09 13:23:52 +0100
commitf8ac788b9584b07b53d16e9b6903f63d939eb9b1 (patch)
tree0185a70403144fef0b4e615f941d4dcf0c8f203e /gnu/packages/games.scm
parente5667edf5027ae7efd78eb5abaf0b0b5150454a9 (diff)
downloadguix-f8ac788b9584b07b53d16e9b6903f63d939eb9b1.tar.gz
gnu: sdlpop: Fix executable location.
* gnu/packages/games.scm (sdlpop)[arguments]: Substitute location of executable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 78e9f17146..cad9200a7f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12642,7 +12642,7 @@ get attention, so you get found.")
                 "1yy5r1r0hv0xggk8qd8bwk2zy7abpv89nikq4flqgi53fc5q9xl7"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ; no tests provided
+     `(#:tests? #f                      ; no tests provided
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)
@@ -12666,6 +12666,8 @@ get attention, so you get found.")
                (chdir "..")
                (install-file "prince" bin)
                (substitute* template (("\\$ROOT") out))
+               (substitute* "src/seg009.c"
+                 (("g_argv[0]") (string-append "\"" out "\"")))
                (install-file template app)
                (rename-file (string-append app "/SDLPoP.desktop.template")
                             (string-append app "/SDLPoP.desktop"))