summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-10 17:07:15 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-08-20 12:26:58 +0200
commitbfadab9177866f0d638449451e1dbde2b36c3d51 (patch)
tree1e5adb8b7c6e02f0bbde3a1d1a082b8c42628bfc /gnu/packages/games.scm
parent27952318a58fe264080c351615cc73d40ed458c0 (diff)
downloadguix-bfadab9177866f0d638449451e1dbde2b36c3d51.tar.gz
gnu: minetest: Respect --without-tests.
* gnu/packages/games.scm
  (minetest)[arguments]<#:phases>{check}: Use 'tests?' instead
  of ',(%current-target-system)'. Remove trailing #t.

Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 28cd0cdc71..37d658ee13 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3633,13 +3633,12 @@ match, cannon keep, and grave-itation pit.")
                      (string-append (getcwd) "/games")) ; for check
              #t))
          (replace 'check
-           (lambda _
+           (lambda* (#:key tests? #:allow-other-keys)
              ;; Thanks to our substitutions, the tests should also run
              ;; when invoked on the target outside of `guix build'.
-             (unless ,(%current-target-system)
+             (when tests?
                (setenv "HOME" "/tmp")
-               (invoke "src/minetest" "--run-unittests"))
-             #t)))))
+               (invoke "src/minetest" "--run-unittests")))))))
     (native-search-paths
      (list (search-path-specification
             (variable "MINETEST_SUBGAME_PATH")