summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-11-06 14:06:58 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-04-19 20:28:00 +0200
commitf044d951b0122b15199efeba396bbe584f8ef86d (patch)
treef988bbcadc781feae4300457885c43b9ff556a3d /gnu/packages/games.scm
parente597612bf3ae205e6baf24abee96b9d680367b00 (diff)
downloadguix-f044d951b0122b15199efeba396bbe584f8ef86d.tar.gz
gnu: openttd: Let the music play.
* gnu/packages/games.scm (openttd)[inputs]: Remove timidity++.
Add fluidsynth and freepats-gm.
[#:phases]<patch-sources>: New phase.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index de398c297f..ae3636596d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4448,6 +4448,15 @@ Transport Tycoon Deluxe.")
          (list (string-append "-DCMAKE_INSTALL_BINDIR=" out "/bin")))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-sources
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "src/music/fluidsynth.cpp"
+               (("default_sf\\[\\] = \\{" all)
+                (string-append all "
+\t/* Guix hardcoded :P */
+\t\"" (string-append (assoc-ref inputs "freepats-gm")
+                     "/share/soundfonts/FreePatsGM.sf2") "\",
+")))))
          (add-before 'check 'install-data
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (for-each
@@ -4457,7 +4466,7 @@ Transport Tycoon Deluxe.")
               (list "opengfx" "openmsx" "opensfx")))))))
     (inputs
      (modify-inputs (package-inputs openttd-engine)
-       (prepend timidity++)))
+       (prepend fluidsynth freepats-gm)))
     (native-inputs
      `(("opengfx" ,openttd-opengfx)
        ("openmsx" ,openttd-openmsx)