summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-18 15:03:41 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-18 15:03:41 +0200
commit642fcb1d08548fa887b4561f2590df62cd8eacbc (patch)
treef97161877f4bb8de45d2a73787a0280aab2e6cac /gnu/packages/games.scm
parenta9798a0abecbd129c502216a340076cf98f9b613 (diff)
downloadguix-642fcb1d08548fa887b4561f2590df62cd8eacbc.tar.gz
gnu: q5go: Fix build.
* gnu/packages/games.scm (q5go)[arguments]: Add 'fix-header' phase.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9d7ba9a73a..88a589551d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10121,6 +10121,11 @@ can be downloaded from @url{https://zero.sjeng.org/best-network}.")
               (("qtchooser -run-tool=(.*) -qt=qt5" _ command)
                command))
             #t))
+        (add-after 'unpack 'fix-header
+          (lambda _
+            (substitute* "src/bitarray.h"
+              (("#include <cstring>" all)
+               (string-append all "\n#include <stdexcept>")))))
         (add-after 'unpack 'fix-paths
           (lambda _
             (substitute* '("src/pics/Makefile.in"