summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-20 18:38:49 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-23 18:49:23 +0800
commit9393ce89ab967823ef693915ed30d4d04a8fc818 (patch)
tree2ee2e078db0212de8ef42f87dd474f394412df52 /gnu/packages/games.scm
parentb262b37f06a166b59aaae835c8981cd91f6b3746 (diff)
downloadguix-9393ce89ab967823ef693915ed30d4d04a8fc818.tar.gz
gnu: alex4: Fix build.
* gnu/packages/games.scm (alex4)[arguments]: Add '-fcommon' to CFLAGS.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 10a3b919ba..7cc9205959 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -430,7 +430,7 @@ mouse and joystick control, and original music.")
      `(#:tests? #f                      ; no check target
        #:make-flags
        (list "CC=gcc"
-             "CFLAGS=-D_FILE_OFFSET_BITS=64"
+             "CFLAGS=-D_FILE_OFFSET_BITS=64 -fcommon"
              (string-append "PREFIX=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases