summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-19 16:25:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-19 19:52:01 +0200
commit677bc34d5b75d4c9a8020f9d0f917c3ca2fb3dc6 (patch)
treeadd93700da018de01a67a18eea8747752f2a17b1 /gnu/packages/games.scm
parent5857a0658a63cad0b32bc8a5a6770e2a57c0b500 (diff)
downloadguix-677bc34d5b75d4c9a8020f9d0f917c3ca2fb3dc6.tar.gz
gnu: Remove redundant cmake libdir configure flags.
* gnu/packages/bioinformatics.scm (imp)[arguments]: Remove
CMAKE_INSTALL_LIBDIR flag.
* gnu/packages/calendar.scm (libical): Same.
* gnu/packages/engineering.scm (kicad): Same.
* gnu/packages/games.scm (openrct2, mgba): Same.
* gnu/packages/gl.scm (virtualgl): Same.
* gnu/packages/image-processing.scm (mia): Same.
* gnu/packages/linux.scm (rdma-core): Same.
* gnu/packages/machine-learning.scm (dlib): Same.
* gnu/packages/maths.scm (lapack, superlu, z3): Same.
* gnu/packages/password-utils.scm (keepassxc): Same.
* gnu/packages/photo.scm (darktable): Same.
* gnu/packages/rdesktop.scm (freerdp): Same.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b8e306a941..df9eed72e8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2778,9 +2778,6 @@ Transport Tycoon Deluxe.")
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f ;; no tests available
-       #:configure-flags
-        (list (string-append "-DCMAKE_INSTALL_LIBDIR="
-                       (assoc-ref %outputs "out") "/lib"))
        #:phases
         (modify-phases %standard-phases
           (add-after 'unpack 'fix-usr-share-paths
@@ -3285,13 +3282,7 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
      `(#:tests? #f                      ;no "test" target
        #:configure-flags
        (list "-DUSE_LZMA=OFF"           ;do not use bundled LZMA
-             "-DUSE_LIBZIP=OFF"         ;use "zlib" instead
-             ;; Validate RUNPATH phase fails ("error: depends on
-             ;; 'libmgba.so.0.6', which cannot be found in RUNPATH") without
-             ;; the following S-exp.
-             (string-append "-DCMAKE_INSTALL_LIBDIR="
-                            (assoc-ref %outputs "out")
-                            "/lib"))))
+             "-DUSE_LIBZIP=OFF")))      ;use "zlib" instead
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("ffmpeg" ,ffmpeg)
               ("imagemagick" ,imagemagick)