summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-26 15:48:26 -0500
committerMark H Weaver <mhw@netris.org>2014-12-26 15:50:32 -0500
commit977736fc4064e6575abde12dbfe7bb79afad54be (patch)
treefab75744b90cb10eca9022445a570bb5c4a56140 /gnu/packages/games.scm
parent8a984cb3072fe769ddd2bcefac873222f8f474b6 (diff)
downloadguix-977736fc4064e6575abde12dbfe7bb79afad54be.tar.gz
gnu: irrlicht: Fix build with mesa-10.
* gnu/packages/patches/irrlicht-mesa-10.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/games.scm (irrlicht): Add patch.  Add glu to inputs.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2dadca620a..b8696a5379 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -611,14 +611,21 @@ buffers, and audio capture.")
                     (and (zero? (system* "unzip" source))
                          ;; The actual source is buried a few directories deep.
                          (chdir "irrlicht-1.8.1/source/Irrlicht/")))
-                  ;; No configure script
-                  (alist-delete 'configure %standard-phases)))
+                  (alist-cons-after
+                   'unpack 'apply-patch/mesa-10-fix
+                   (lambda* (#:key inputs #:allow-other-keys)
+                     (zero? (system* "patch" "--force" "-p3" "-i"
+                                     (assoc-ref inputs "patch/mesa-10-fix"))))
+                   ;; No configure script
+                   (alist-delete 'configure %standard-phases))))
        #:tests? #f ; no check target
        #:make-flags '("CC=gcc" "sharedlib")))
     (native-inputs
-     `(("unzip" ,unzip)))
+     `(("patch/mesa-10-fix" ,(search-patch "irrlicht-mesa-10.patch"))
+       ("unzip" ,unzip)))
     (inputs
-     `(("mesa" ,mesa)))
+     `(("mesa" ,mesa)
+       ("glu" ,glu)))
     (synopsis "3D game engine written in C++")
     (description
      "The Irrlicht Engine is a high performance realtime 3D engine written in