summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-27 09:30:01 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-27 09:30:01 +0200
commit01497dfe6c0a2ce69287d0fd0008747965a000df (patch)
treef7f6f53baf6e81a8bce26144c550da3bf4b9df5c /gnu/packages/games.scm
parent74c8b174e8015de753ba5cab44f76f944e6fd4ba (diff)
downloadguix-01497dfe6c0a2ce69287d0fd0008747965a000df.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm96
1 files changed, 96 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b0bf4e3546..39fc6f2666 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2396,3 +2396,99 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
 your way through an underground cave system in search of the Grue.  Can you
 capture it and get out alive?")
     (license license:agpl3+)))
+
+(define-public warzone2100
+  (package
+    (name "warzone2100")
+    (version "3.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/" name
+                                  "/releases/" version "/" name "-" version
+                                  ".tar.xz"))
+              (sha256
+               (base32
+                "0hm49i2knvvg3wlnryv7h4m84s3qa7jfyym5yy6365sx8wzcrai1"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'set-paths 'set-sdl-paths
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (setenv "CPATH"
+                              (string-append (assoc-ref inputs "sdl-union")
+                                             "/include/SDL"))
+                      #t)))))
+    (native-inputs `(("pkg-config" ,pkg-config)
+                     ("unzip" ,unzip)
+                     ("zip" ,zip)))
+    (inputs `(("fontconfig" ,fontconfig)
+              ("freetype" ,freetype)
+              ("fribidi" ,fribidi)
+              ("glew" ,glew)
+              ("libtheora" ,libtheora)
+              ("libvorbis" ,libvorbis)
+              ("libxrandr" ,libxrandr)
+              ("openal" ,openal)
+              ("physfs" ,physfs)
+              ("qt", qt-4)
+              ("quesoglc" ,quesoglc)
+              ("sdl-union" ,(sdl-union))))
+    (home-page "http://wz2100.net")
+    (synopsis "3D Real-time strategy and real-time tactics game")
+    (description
+     "Warzone 2100 offers campaign, multi-player, and single-player skirmish
+modes. An extensive tech tree with over 400 different technologies, combined
+with the unit design system, allows for a wide variety of possible units and
+tactics.")
+    ; Everything is GPLv2+ unless otherwise specified in COPYING.NONGPL
+    (license (list license:bsd-3
+                   license:cc0
+                   license:cc-by-sa3.0
+                   license:expat
+                   license:gpl2+
+                   license:lgpl2.1+))))
+
+(define-public starfighter
+  (package
+    (name "starfighter")
+    (version "1.5.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://savannah/starfighter/"
+                    (version-major+minor version) "/"
+                    name "-" version "-src.tar.gz"))
+              (sha256
+               (base32
+                "1qc0hhw9m8sy3n9fips52c7aph3w8a8pdl4n45yaasgxzbvpn9xg"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f ; no check target
+       #:make-flags
+       (let ((out (assoc-ref %outputs "out")))
+         (list (string-append "PREFIX=" out)
+               (string-append "BINDIR=" out "/bin/")))
+       #:phases
+       (modify-phases %standard-phases
+         ;; no configure script
+         (delete 'configure))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("sdl2" ,sdl2)
+       ("sdl2-image" ,sdl2-image)
+       ("sdl2-mixer" ,sdl2-mixer)))
+    (home-page "http://starfighter.nongnu.org/")
+    (synopsis "2D scrolling shooter game")
+    (description
+     "In the year 2579, the intergalactic weapons corporation, WEAPCO, has
+dominated the galaxy.  Guide Chris Bainfield and his friend Sid Wilson on
+their quest to liberate the galaxy from the clutches of WEAPCO.  Along the
+way, you will encounter new foes, make new allies, and assist local rebels
+in strikes against the evil corporation.")
+    ;; gfx and music are under CC-BY 3.0, CC-BY-SA 3.0, CC0 or Public Domain.
+    (license (list license:gpl3+
+                   license:cc-by3.0
+                   license:cc-by-sa3.0
+                   license:cc0
+                   license:public-domain))))