summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-02 14:22:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-02 14:45:52 +0200
commit359a57b6e12aac05847c1dbee397a16c7b1d9559 (patch)
tree7fe5b04a036c43d4517da8696733c7cbf2d49dcf /gnu/packages/games.scm
parentab0ede51c041927a1c35535aec3504f84d7a9751 (diff)
downloadguix-359a57b6e12aac05847c1dbee397a16c7b1d9559.tar.gz
gnu: alex4: Don't use unstable tarball.
* gnu/packages/games.scm (alex4)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 42da7e689a..67395e6e12 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -256,14 +256,16 @@ mouse and joystick control, and original music.")
     (version "1.2-alpha")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/carstene1ns/alex4/archive/"
-                           version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/carstene1ns/alex4.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0jj1g3v1a6lyfwp5g2ly0n9z65ryqck8jxvzr01kaqjj3lsfkrhg"))))
+        (base32 "104nlhdsv1sg9g08fh5adwazw80400081awy7jsrn842srca0q1f"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ; no check target
+     `(#:tests? #f                      ; no check target
        #:make-flags
        (list "-Csrc"
              "CC=gcc"