summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-04-12 22:03:51 -0500
committerEric Bavier <bavier@member.fsf.org>2018-04-12 22:03:51 -0500
commit6a03ccf4a1f541ff167805c4b7656c21dba10f3e (patch)
tree5a2edebcfc72583d22d9630d7704cb240f359eda /gnu/packages/games.scm
parent306d8630dc2cb6d802a86630e301d49da04149e8 (diff)
downloadguix-6a03ccf4a1f541ff167805c4b7656c21dba10f3e.tar.gz
gnu: pioneer: Update to 20180203.
* gnu/packages/games.scm (pioneer): Update to 20180203.
[source]: Use git-fetch method to avoid github tarball.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5207e08d6c..b7eda0fdc4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4607,15 +4607,16 @@ elements to achieve a simple goal in the most complex way possible.")
 (define-public pioneer
   (package
     (name "pioneer")
-    (version "20171001")
+    (version "20180203")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/pioneerspacesim/pioneer/"
-                                  "archive/" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pioneerspacesim/pioneer.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1nxhx22swfqq6lfvcnpfm31wig3sjv5pp0rslj79nbxc7nyihh8m"))))
+                "0hp2mf36kj2v93hka8m8lxw2qhmnjc62wjlpw7c7ix0r8xa01i6h"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)