summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-27 16:07:16 +0100
committerMarius Bakke <marius@gnu.org>2022-12-02 19:08:27 +0100
commitea0e6e5d654c8cbc5f42e6b57c3739bb6216a9f5 (patch)
treecec3a8377489c24b48899e12d3784052aee8186d /gnu/packages/games.scm
parent6aac95ae2b522812aa9c64b84de22c640e90820f (diff)
downloadguix-ea0e6e5d654c8cbc5f42e6b57c3739bb6216a9f5.tar.gz
gnu: golly: Update to 4.2.
* gnu/packages/games.scm (golly): Update to 4.2.
[arguments]: Remove configure phase.
[inputs]: Remove PYTHON-2 and WXWIDGETS-GTK2.  Add PYTHON, SDL2, and
WXWIDGETS.  Remove labels while at it.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm22
1 files changed, 4 insertions, 18 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index bd46ad7392..661d727d79 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1427,7 +1427,7 @@ real-time combat.")
 (define-public golly
   (package
     (name "golly")
-    (version "3.3")
+    (version "4.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/golly/golly/golly-"
@@ -1435,7 +1435,7 @@ real-time combat.")
                                   "-src.tar.gz"))
               (sha256
                (base32
-                "1j3ksnar4rdam4xiyspgyrs1pifbvxfxkrn65brkwxpx39mpgzc8"))))
+                "0pg9cp83nxc354lizgza5bqdy7z5wh36863203zw6r6s4flji4an"))))
     (build-system gnu-build-system)
     (arguments
      '(#:make-flags (list "CC=gcc"
@@ -1445,17 +1445,7 @@ real-time combat.")
        #:tests? #f ; no check target
        #:phases
        (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key inputs #:allow-other-keys)
-             ;; For some reason, setting the PYTHON_SHLIB make flag doesn't
-             ;; properly set the path to the Python shared library. This
-             ;; substitution acheives the same end by different means.
-             (substitute* "gui-wx/wxprefs.cpp"
-               (("pythonlib = wxT\\(STRINGIFY\\(PYTHON_SHLIB\\)\\)")
-                (string-append "pythonlib = \""
-                               (assoc-ref inputs "python")
-                               "/lib/libpython-2.7.so\"")))
-             #t))
+         (delete 'configure)
          (replace 'build
            (lambda* (#:key make-flags outputs #:allow-other-keys)
              (with-directory-excursion "gui-wx"
@@ -1485,11 +1475,7 @@ real-time combat.")
     (native-inputs
      (list lua))
     (inputs
-     `(("glu" ,glu)
-       ("mesa" ,mesa)
-       ("python" ,python-2)
-       ("wxwidgets" ,wxwidgets-gtk2)
-       ("zlib" ,zlib)))
+     (list glu mesa python sdl2 wxwidgets zlib))
     (home-page "http://golly.sourceforge.net/")
     (synopsis "Software for exploring cellular automata")
     (description