summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-08-22 15:53:27 -0400
committerMark H Weaver <mhw@netris.org>2019-08-22 15:53:27 -0400
commit893c2df00daa4e6dd6a7ff3813d7df5329877f9e (patch)
treeacd0db459464acae47083b66d5ce12cc656e2f10 /gnu/packages/games.scm
parent04b9b7bb05aff4c41f46cd79aa7bc953ace16e86 (diff)
parent0ccc9a0f5bb89b239d56157ea66f8420fcec5ba6 (diff)
downloadguix-893c2df00daa4e6dd6a7ff3813d7df5329877f9e.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1aa2f92c02..3dc3c72551 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1386,7 +1386,7 @@ that beneath its ruins lay buried an ancient evil.")
 (define-public angband
   (package
     (name "angband")
-    (version "4.1.3")
+    (version "4.2.0")
     (source
      (origin
        (method url-fetch)
@@ -1395,7 +1395,7 @@ that beneath its ruins lay buried an ancient evil.")
                            "/angband-" version ".tar.gz"))
        (sha256
         (base32
-         "0vs0314lbdc6rzxn4jnb7zp6n1p1cdb8r53savadn7k9vbwc80ll"))
+         "0vdm1ymm28wawp94nl1p5q3lhc0k7cnn2kkvvrkfx962gif4kqfk"))
        (modules '((guix build utils)))
        (snippet
         ;; So, some of the sounds/graphics/tilesets are under different
@@ -1409,7 +1409,7 @@ that beneath its ruins lay buried an ancient evil.")
                          (delete-file-recursively lib-subdir)))
                      '("fonts" "icons" "sounds" "tiles"))
            (substitute* "lib/Makefile"
-             ;; And don't try to invoke makefiles in the directories we removed
+             ;; And don't try to invoke makefiles in the directories we removed.
              (("gamedata customize help screens fonts tiles sounds icons user")
               "gamedata customize help screens user"))
            #t))))
@@ -2340,15 +2340,15 @@ on the screen and keyboard to display letters.")
 (define-public manaplus
   (package
     (name "manaplus")
-    (version "1.7.6.10")
+    (version "1.9.3.23")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "http://repo.manaplus.org/manaplus/download/"
+                    "https://repo.manaplus.org/manaplus/download/"
                     version "/manaplus-" version ".tar.xz"))
               (sha256
                (base32
-                "0l7swvpzq20am4w2rsjpp6fsvbjv07il6wbfy45a7h9zsdihmqhl"))))
+                "1ky182p4svwdqm6cf7jbns85hidkhkhq4s17cs2p381f0klapfjz"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
@@ -2363,7 +2363,7 @@ on the screen and keyboard to display letters.")
        ("libxml2" ,libxml2)
        ("mesa" ,mesa)
        ("sdl-union" ,(sdl-union))))
-    (home-page "http://manaplus.org")
+    (home-page "https://manaplus.org")
     (synopsis "Client for 'The Mana World' and similar games")
     (description
      "ManaPlus is a 2D MMORPG client for game servers.  It is the only
@@ -2828,7 +2828,7 @@ players.")
     (version "2.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://http.debian.net/debian/pool/main/e/"
+              (uri (string-append "mirror://debian/pool/main/e/"
                                   "einstein/einstein_2.0.dfsg.2.orig.tar.gz"))
               (sha256
                (base32