summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 05:09:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 05:11:31 +0200
commita8f52ad7c1c6fdb33a97989ae546119c256a662b (patch)
tree303648a8e8fb0426945bfd39d7e1d2bb55cd733c /gnu/packages/games.scm
parent0458ec2b031401f269f0429be01ee3efee817ad6 (diff)
downloadguix-a8f52ad7c1c6fdb33a97989ae546119c256a662b.tar.gz
gnu: laby: Fix build.
* gnu/packages/games.scm (laby)[inputs]: Add ocamlbuild.
[arguments]: Add new ’allow-unsafe-strings’ phase.
Rename ’setenv’ phase to the more meaningful ’set-library-path’.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c032c4cfce..0b93409c76 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3542,12 +3542,19 @@ Linux / Mac OS X servers, and an auto mapper with a VT100 map display.")
     (inputs
      `(("lablgtk" ,lablgtk)
        ("ocaml" ,ocaml)
-       ("ocaml-findlib" ,ocaml-findlib)))
+       ("ocaml-findlib" ,ocaml-findlib)
+       ("ocamlbuild" ,ocamlbuild)))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (delete 'configure)
-         (add-before 'build 'setenv
+         (add-before 'build 'allow-unsafe-strings
+           ;; Fix a build failure with ocaml >=4.06.0.
+           ;; See <https://github.com/sgimenez/laby/issues/53>.
+           (lambda _
+             (setenv "OCAMLPARAM" "safe-string=0,_")
+             #t))
+         (add-before 'build 'set-library-path
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((lablgtk (assoc-ref inputs "lablgtk")))
                (setenv "LD_LIBRARY_PATH"