summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-09 21:54:57 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-09 21:54:57 +0200
commit03f0b5e2c66d5b88027c813dc47ae0bdfe009ca7 (patch)
treed5a1e11191104861f0c0b0697c35f20e00a45238 /gnu/packages/games.scm
parent7f486d25d2a54337d4513853aade47d895e5638c (diff)
downloadguix-03f0b5e2c66d5b88027c813dc47ae0bdfe009ca7.tar.gz
gnu: wesnoth: Update to 1.14.9.
Fixes a build failure reported by reepca on #guix.

* gnu/packages/games.scm (wesnoth): Update to 1.14.9.
[arguments]: Add phase to disable compiler warnings from Boost headers.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d68f6aa451..1b6849a9aa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2435,7 +2435,7 @@ falling, themeable graphics and sounds, and replays.")
 (define-public wesnoth
   (package
     (name "wesnoth")
-    (version "1.14.7")
+    (version "1.14.9")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/wesnoth/wesnoth-"
@@ -2444,10 +2444,23 @@ falling, themeable graphics and sounds, and replays.")
                                   "wesnoth-" version ".tar.bz2"))
               (sha256
                (base32
-                "0j2yvkcggj5k0r2cqk8ndnj77m37a00srfd9qg7pdpqffbinqpj7"))))
+                "1mhdrlflxxyknf54lwdbvs7fazlc1scf7z6vxxa3j746fks533ga"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f))                    ; no check target
+     `(#:tests? #f                      ;no check target
+       #:phases (modify-phases %standard-phases
+                  (add-before 'configure 'treat-boost-as-system-header
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (let ((boost (assoc-ref inputs "boost")))
+                        ;; Ensure Boost is treated as "system headers" to
+                        ;; pacify compiler warnings induced by Boost headers.
+                        (for-each (lambda (variable)
+                                    (setenv variable
+                                            (string-append boost "/include:"
+                                                           (or (getenv variable)
+                                                               ""))))
+                                  '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH"))
+                        #t))))))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)))