summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-22 22:51:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-22 22:51:27 +0100
commit02296cb0c8bff29e82cdfc48bf59f4648db7d6b2 (patch)
treeb0a56956a8b6724a4f2be2c56c549c5cc52707db /gnu/packages/games.scm
parent3e678de04c86b99d4a7c0128a975e40a3a59f2cc (diff)
downloadguix-02296cb0c8bff29e82cdfc48bf59f4648db7d6b2.tar.gz
gnu: jumpnbump: Add -fcommon to CFLAGS.
* gnu/packages/games.scm (jumpnbump)[arguments]: Replace 'configure phase to
add -fcommon to CFLAGS.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e9f4586a29..65c05a9018 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9416,7 +9416,14 @@ simulator.")
        #:tests? #f                      ;no test
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)            ;no configure script
+         ;; There is no configure script
+         (replace 'configure
+           (lambda _
+             (substitute* "Makefile"
+               (("-funroll-loops")
+                "-funroll-loops -fcommon")
+               (("SDL_CFLAGS =")
+                "SDL_CFLAGS = -fcommon"))))
          (add-after 'unpack 'fix-sdl-path
            ;; XXX: For some reason, `sdl2-config' reports stand-alone SDL
            ;; directory, not SDL-union provided as an input to the package.