summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-08-31 10:00:54 -0400
committerJulien Lepiller <julien@lepiller.eu>2021-09-01 03:34:10 +0200
commit1a657497acdead9afbeb24db6102f645d7e28ac9 (patch)
tree252d3f4c1fa28accafa26adb13e405bfdf5315db /gnu/packages/games.scm
parentcefaa0e60726cf05fa7adff0f3949e57ba76b34a (diff)
downloadguix-1a657497acdead9afbeb24db6102f645d7e28ac9.tar.gz
gnu: Remove harmonist-tk.
harmonist-tk has been superseded by harmonist-sdl.  Current harmonist-tk
package fails to build due to upgrade of harmonist to 0.4.1.

* gnu/packages/games.scm (harmonist-tk): Remove variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5e200f425..1a9cd36fee 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9460,26 +9460,6 @@ the game avoids complex inventory management and character building, relying
 on items and player adaptability for character progression.")
     (license license:isc)))
 
-(define-public harmonist-tk
-  (package
-    (inherit harmonist)
-    (name "harmonist-tk")
-    (arguments
-      (append
-        (package-arguments harmonist)
-        `(#:phases
-          (modify-phases %standard-phases
-            (replace 'build
-              (lambda _
-                (invoke "go" "install" "-v" "-x" "--tags" "tk"
-                        "git.tuxfamily.org/harmonist/harmonist")))
-            (replace 'check
-              (lambda _
-                (invoke "go" "test" "--tags" "tk"
-                        "git.tuxfamily.org/harmonist/harmonist")))))))
-    (inputs
-     `(("go-github.com-nsf-gothic" ,go-github.com-nsf-gothic)))))
-
 (define-public drascula
   (package
     (name "drascula")