summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-12 21:42:06 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-12 21:42:06 +0200
commitadc90e0eac3cb326cd687f80514dad6a5240969d (patch)
tree6335b4b8cded5dc1518b5494762cdb09d8acbab1 /gnu/packages/gawk.scm
parenta8bc747ae1ba53c4c8719730284a771187d8ccfb (diff)
parent9765b3aeac88ae9c9ffc38ed6d1f8dcbd9abca7b (diff)
downloadguix-adc90e0eac3cb326cd687f80514dad6a5240969d.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index d2639a32a3..6bfea34667 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -57,17 +57,7 @@
                                (string-append "### " match))))
                           '())))
 
-                (alist-cons-before
-                 'check 'install-locales
-                 (lambda _
-                   ;; A bunch of tests require the availability of a UTF-8
-                   ;; locale and otherwise fail.  Since UTF-8 locales are not
-                   ;; available during bootstrap, create one here.
-                   (setenv "LOCPATH" (getcwd))
-                   (zero? (system* "localedef" "--no-archive"
-                                   "--prefix" (getcwd) "-i" "en_US"
-                                   "-f" "UTF-8" "./en_US.UTF-8")))
-                 %standard-phases))))
+                %standard-phases)))
    (inputs `(("libsigsegv" ,libsigsegv)
 
              ,@(if (%current-target-system)