summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-26 23:34:34 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-26 23:34:34 +0100
commite9bab1df6d4c71f9617362c2bd8babe61dec759d (patch)
tree05e0a7cc69150d8fd9716329d70079775cf7e799 /gnu/packages/gawk.scm
parent094b2efc3c672d60c2fbaca68ce632ba6ab54700 (diff)
downloadguix-e9bab1df6d4c71f9617362c2bd8babe61dec759d.tar.gz
gnu: gawk: Build a UTF-8 locale for the tests.
* gnu/packages/gawk.scm (gawk)[arguments]: Add 'install-locales' phase.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 10506197f3..996be7af4a 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -64,7 +64,17 @@
                           '((substitute* "extension/configure"
                               (("/usr/bin/file") (which "file"))))
                           '())))
-                %standard-phases)))
+
+                (alist-cons-before
+                 'check 'install-locales
+                 (lambda _
+                   ;; A bunch of tests require the availability of a UTF-8
+                   ;; locale and otherwise fail.  Give them what they want.
+                   (setenv "LOCPATH" (getcwd))
+                   (zero? (system* "localedef" "--no-archive"
+                                   "--prefix" (getcwd) "-i" "en_US"
+                                   "-f" "UTF-8" "./en_US.UTF-8")))
+                 %standard-phases))))
    (inputs `(("libsigsegv" ,libsigsegv)
 
              ,@(if (%current-target-system)