summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-01 00:07:26 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-01 00:07:26 +0200
commit63c0c19a64773da0bbbd54b5bd07b9240246eb68 (patch)
tree6b7cdc0a8580f2912e1db6e5a1d46619dbbd9682 /gnu/packages/gawk.scm
parent8caa6152d0011948c89147124c8e3592fd0ba547 (diff)
downloadguix-63c0c19a64773da0bbbd54b5bd07b9240246eb68.tar.gz
gnu: gawk: Refer to the target Bash in io.c.
* gnu/packages/gawk.scm (gawk): Add Bash as an input
  when (%current-target-system) is true.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 34a119f05b..444fa5e556 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -18,6 +18,7 @@
 
 (define-module (gnu packages gawk)
   #:use-module (guix licenses)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages libsigsegv)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -45,18 +46,20 @@
                 (lambda* (#:key inputs #:allow-other-keys)
                   ;; Refer to the right shell.
                   ;; FIXME: Remove `else' arm upon core-updates.
-                  ,(if (%current-target-system)
-                       '(let ((sh (which "sh")))
-                          (substitute* "io.c"
-                            (("/bin/sh") sh)))
-                       '(let ((bash (assoc-ref inputs "bash")))
-                          (substitute* "io.c"
-                            (("/bin/sh")
-                             (string-append bash "/bin/bash"))))))
+                  (let ((bash (assoc-ref inputs "bash")))
+                    (substitute* "io.c"
+                      (("/bin/sh")
+                       (string-append bash "/bin/bash")))))
                 ,(if (%current-target-system)
                      '%standard-cross-phases
                      '%standard-phases))))
-   (inputs `(("libsigsegv" ,libsigsegv)))
+   (inputs `(("libsigsegv" ,libsigsegv)
+
+             ;; TODO: On next core-updates, make Bash input unconditional.
+             ,@(if (%current-target-system)
+                   `(("bash" ,bash))
+                   '())))
+
    (home-page "http://www.gnu.org/software/gawk/")
    (synopsis "A text scanning and processing language")
    (description