summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-02 15:38:30 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-02 15:39:10 +0200
commit3964e358ab65dfd157427560bfb44de8a150068b (patch)
tree7a5bb38a87cf420c5ce0daf2d30cec944848f68a /gnu/packages/gawk.scm
parente0649ff3c0db17a27999da36cf9bd9fead8df4c7 (diff)
downloadguix-3964e358ab65dfd157427560bfb44de8a150068b.tar.gz
gnu: gawk: Use 'modify-phases'.
* gnu/packages/gawk.scm (gawk)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm58
1 files changed, 28 insertions, 30 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 9852f760e0..86f01335a8 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -40,40 +40,38 @@
    (arguments
     `(#:parallel-tests? #f                ; test suite fails in parallel
 
-      #:phases (alist-cons-before
-                'configure 'set-shell-file-name
-                (lambda* (#:key inputs #:allow-other-keys)
-                  ;; Refer to the right shell.
-                  (let ((bash (assoc-ref inputs "bash")))
-                    (substitute* "io.c"
-                      (("/bin/sh")
-                       (string-append bash "/bin/bash")))
+      #:phases (modify-phases %standard-phases
+                 (add-before 'configure 'set-shell-file-name
+                   (lambda* (#:key inputs #:allow-other-keys)
+                     ;; Refer to the right shell.
+                     (let ((bash (assoc-ref inputs "bash")))
+                       (substitute* "io.c"
+                         (("/bin/sh")
+                          (string-append bash "/bin/bash")))
 
-                    ;; When cross-compiling, remove dependencies on the
-                    ;; `check-for-shared-lib-support' target, which tries to
-                    ;; run the cross-built `gawk'.
-                    ,@(if (%current-target-system)
-                          '((substitute* "extension/Makefile.in"
-                              (("^.*: check-for-shared-lib-support" match)
-                               (string-append "### " match))))
-                          '())))
+                       ;; When cross-compiling, remove dependencies on the
+                       ;; `check-for-shared-lib-support' target, which tries
+                       ;; to run the cross-built `gawk'.
+                       ,@(if (%current-target-system)
+                             '((substitute* "extension/Makefile.in"
+                                 (("^.*: check-for-shared-lib-support" match)
+                                  (string-append "### " match))))
+                             '()))))
 
-                (alist-cons-before
-                 'check 'adjust-test-infrastructure
-                 (lambda _
-                   ;; Remove dependency on 'more' (from util-linux), which
-                   ;; would needlessly complicate bootstrapping.
-                   (substitute* "test/Makefile"
-                     (("\\| more") ""))
+                 (add-before 'check 'adjust-test-infrastructure
+                   (lambda _
+                     ;; Remove dependency on 'more' (from util-linux), which
+                     ;; would needlessly complicate bootstrapping.
+                     (substitute* "test/Makefile"
+                       (("\\| more") ""))
 
-                   ;; Adjust the shebang in that file since it is then diff'd
-                   ;; against the actual test output.
-                   (substitute* "test/watchpoint1.ok"
-                     (("#! /usr/bin/gawk")
-                      (string-append "#!" (which "gawk"))))
-                   #t)
+                     ;; Adjust the shebang in that file since it is then diff'd
+                     ;; against the actual test output.
+                     (substitute* "test/watchpoint1.ok"
+                       (("#! /usr/bin/gawk")
+                        (string-append "#!" (which "gawk"))))
+                     #t)))))
 
-                 %standard-phases))))
    (inputs `(("libsigsegv" ,libsigsegv)
 
              ,@(if (%current-target-system)