summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-06-27 23:38:21 +0800
committerEfraim Flashner <efraim@flashner.co.il>2024-07-02 13:19:37 +0300
commitb1c917779a0d848de92ee5b02575629336e35237 (patch)
tree4c4a35a7c5f8414146e4d694e8ddfc2707ae0fd8 /gnu/packages/gcc.scm
parent7f29030cd85e5e8c5110e4772ee4491a7a3d41a3 (diff)
downloadguix-b1c917779a0d848de92ee5b02575629336e35237.tar.gz
gnu: Add gcc-14.
* gnu/packages/gcc.scm (gcc-14): New variable.

Change-Id: I7eca4e35e010a69c13489c10c72c29d6e628bb72
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 3184a8b6a0..f44030355e 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -830,6 +830,29 @@ It also includes runtime support libraries for these languages.")
         ("x86_64" ,@%gcc-13-x86_64-micro-architectures))
        ,@(package-properties gcc-11)))))
 
+(define-public gcc-14
+  (package
+    (inherit gcc-13)
+    (version "14.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/gcc/gcc-"
+                                  version "/gcc-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0h3889kkfp9bzw8km9w1ssh5qjskg6yw02q8v3lkvzksk1acd0z2"))
+              (patches (search-patches "gcc-12-strmov-store-file-names.patch"
+                                       "gcc-5.0-libvtv-runpath.patch"))
+              (modules '((guix build utils)))
+              (snippet gcc-canadian-cross-objdump-snippet)))
+    (arguments (substitute-keyword-arguments (package-arguments gcc-13)
+                 ((#:phases phases #~%standard-phases)
+                  #~(modify-phases #$phases
+                      (add-before 'configure 'pre-x86-configure
+                        (lambda _
+                          (substitute* "gcc/config/i386/t-linux64"
+                            (("\\.\\./lib64") "../lib"))))))))))
+
 
 ;; Note: When changing the default gcc version, update
 ;;       the gcc-toolchain-* definitions.