summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-01 14:37:46 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:51 +0200
commitbc78aebc637272fe515830297df1806647b5a7da (patch)
treef07ebc02bd6f9f21f62506de2bad607be07e416f /gnu/packages/gcc.scm
parent390867226182a685f476b7bd1c856674fdcfd51c (diff)
downloadguix-bc78aebc637272fe515830297df1806647b5a7da.tar.gz
gnu: gcc: Patch crypt out of bundled libsanitizer.
* gnu/packages/patches/gcc-10-libsanitizer-no-crypt.patch:
* gnu/packages/patches/gcc-12-libsanitizer-no-crypt.patch:
* gnu/packages/patches/gcc-13-libsanitizer-no-crypt.patch: New patches.
* gnu/local.mk (dist_patch_DATA): Register them.
* gnu/packages/gcc.scm (gcc-10, gcc-11, gcc-12, gcc-13): Use them.

Change-Id: Idc450c5a468e07c4ea78c8ca7bb1c5ee379231bb
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 4350407d63..347752b4ee 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -717,7 +717,8 @@ It also includes runtime support libraries for these languages.")
              (base32
               "1h87lcfaga0ydsf4pkhwlnjr8mky5ix8npbv6iy3jvzlzm1ra415"))
             (patches (search-patches "gcc-9-strmov-store-file-names.patch"
-                                     "gcc-5.0-libvtv-runpath.patch"))
+                                     "gcc-5.0-libvtv-runpath.patch"
+                                     "gcc-10-libsanitizer-no-crypt.patch"))
             (modules '((guix build utils)))
             (snippet gcc-canadian-cross-objdump-snippet)))
    (properties
@@ -742,6 +743,7 @@ It also includes runtime support libraries for these languages.")
               "1ncd7akww0hl5kkmw1dj3qgqp3phdrr5dfnm7jia9s07n0ib4b9z"))
             (patches (search-patches "gcc-9-strmov-store-file-names.patch"
                                      "gcc-5.0-libvtv-runpath.patch"
+                                     "gcc-10-libsanitizer-no-crypt.patch"
                                      "gcc-11-libstdc++-hurd-libpthread.patch"))
             (modules '((guix build utils)))
             (snippet gcc-canadian-cross-objdump-snippet)))
@@ -767,6 +769,7 @@ It also includes runtime support libraries for these languages.")
                 "0xcida8l2wykvvzvpcrcn649gj0ijn64gwxbplacpg6c0hk6akvh"))
               (patches (search-patches "gcc-12-strmov-store-file-names.patch"
                                        "gcc-5.0-libvtv-runpath.patch"
+                                       "gcc-12-libsanitizer-no-crypt.patch"
                                        "gcc-11-libstdc++-hurd-libpthread.patch"))
               (modules '((guix build utils)))
               (snippet gcc-canadian-cross-objdump-snippet)))
@@ -791,7 +794,8 @@ It also includes runtime support libraries for these languages.")
                (base32
                 "10y0l1hx1haz4cj4d4g9f2ci5h7z9555i52f90zs2hwm3iifji88"))
               (patches (search-patches "gcc-12-strmov-store-file-names.patch"
-                                       "gcc-5.0-libvtv-runpath.patch"))
+                                       "gcc-5.0-libvtv-runpath.patch"
+                                       "gcc-13-libsanitizer-no-crypt.patch"))
               (modules '((guix build utils)))
               (snippet gcc-canadian-cross-objdump-snippet)))
     (arguments