summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-08 00:43:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-08 19:37:47 +0100
commit8d65ae44ac9492b17266aa1bbe04d562e904946a (patch)
tree47ea27236cfb1f2711bbc5b32f1807eed7deb0fc /gnu/packages/gcc.scm
parent91206dffb901ab4d881b6e16cdfbcfd9ba32f357 (diff)
downloadguix-8d65ae44ac9492b17266aa1bbe04d562e904946a.tar.gz
gnu: GCC@6: Update to 6.5.0.
* gnu/packages/patches/gcc-libsanitizer-fix.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/gcc.scm (gcc-6): Update to 6.5.0.
[source](patches): Drop obsolete patches.
[source](snippet): Remove.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm24
1 files changed, 4 insertions, 20 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 8207104174..fb06b53474 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -461,34 +461,18 @@ Go.  It also includes runtime support libraries for these languages.")
 (define-public gcc-6
   (package
     (inherit gcc-5)
-    (version "6.4.0")
+    (version "6.5.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/gcc/gcc-"
                                   version "/gcc-" version ".tar.xz"))
               (sha256
                (base32
-                "1m0lr7938lw5d773dkvwld90hjlcq2282517d1gwvrfzmwgg42w5"))
-              (patches (search-patches "gcc-libsanitizer-fix.patch"
-                                       "gcc-libsanitizer-ustat.patch"
-                                       "gcc-strmov-store-file-names.patch"
+                "0i89fksfp6wr1xg9l8296aslcymv2idn60ip31wr9s4pwin7kwby"))
+              (patches (search-patches "gcc-strmov-store-file-names.patch"
                                        "gcc-6-source-date-epoch-1.patch"
                                        "gcc-6-source-date-epoch-2.patch"
-                                       "gcc-5.0-libvtv-runpath.patch"))
-              (modules '((guix build utils)))
-              ;; This is required for building with glibc-2.26.
-              ;; This can be removed when gcc-6.5.0 is released.
-              ;; https://gcc.gnu.org/bugzilla/show_bug.cgi?id=81712
-              (snippet
-               '(begin
-                  (for-each
-                   (lambda (dir)
-                     (substitute* (string-append "libgcc/config/"
-                                                 dir "/linux-unwind.h")
-                       (("struct ucontext") "ucontext_t")))
-                   '("aarch64" "alpha" "bfin" "i386" "m68k" "nios2"
-                     "pa" "sh" "tilepro" "xtensa"))
-                  #t))))
+                                       "gcc-5.0-libvtv-runpath.patch"))))
     (inputs
      `(("isl" ,isl)
        ,@(package-inputs gcc-4.7)))