summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-09 19:56:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-09 21:58:08 +0200
commit315359a4f3ae4b2ef5431ed2850decff60f7aa9e (patch)
tree30ee17daf5d6cc3fd7611665025725c28e2b86e0 /gnu/packages/gcc.scm
parent58a95d599ee5d0dc6419d038b7317e1b77b11519 (diff)
downloadguix-315359a4f3ae4b2ef5431ed2850decff60f7aa9e.tar.gz
gnu: Add gccgo-12.
* gnu/packages/gcc.scm (gccgo-12): New variable.
(make-gccgo)[arguments]: Adapt custom 'remove-tool-reference-from-libgo
to changes in the source.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index bb154cac62..bf3c753b2d 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014, 2015, 2016, 2017, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2018, 2020-2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
@@ -1062,8 +1062,11 @@ provides the GNU compiler for the Go programming language.")
                  (substitute* "libgo/Makefile.in"
                    (("(GccgoToolDir = \\\")[^\\\"]+" _ start)
                     (string-append start "/nonexistent"))
-                   (("(DefaultGoroot = \\\")[^\\\"]+" _ start)
-                    (string-append start "/nonexistent"))
+                   ,@(if (version>=? (package-version gccgo) "12.0")
+                       '((("(defaultGOROOT = `)[^`]+" _ start)
+                          (string-append start "/nonexistent")))
+                       '((("(DefaultGoroot = \\\")[^\\\"]+" _ start)
+                          (string-append start "/nonexistent"))))
                    (("(defaultGOROOTValue.*?return `)[^`]+" _ start)
                     (string-append start "/nonexistent"))))))))))))
 
@@ -1087,6 +1090,9 @@ provides the GNU compiler for the Go programming language."))
 (define-public gccgo-11
   (make-gccgo gcc-11))
 
+(define-public gccgo-12
+  (make-gccgo gcc-12))
+
 (define %objc-search-paths
   (list (search-path-specification
          (variable "OBJC_INCLUDE_PATH")