summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-18 00:59:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-18 08:41:44 +0300
commit96f8945425c9b43cc083733d2331bc305650c902 (patch)
tree890cbbf4742ffa98482914a808c26a5de526d77d /gnu/packages/gcc.scm
parentd85c254319435c3fcd1fc5842769b9f167f92b14 (diff)
downloadguix-96f8945425c9b43cc083733d2331bc305650c902.tar.gz
gnu: gcc-2.95: Add substitution for the Hurd's linker.
* gnu/packages/gcc.scm (gcc-2.95)[arguments]: Adjust custom
'set-dynamic-linker-file-name phase to also substitute the Hurd's
linker.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 30b2be1f5a..ea9b9e57f4 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -778,6 +778,10 @@ It also includes runtime support libraries for these languages.")
                        (("/lib/ld\\.so\\.1")
                         (search-input-file
                           inputs #$(glibc-dynamic-linker matching-system))))
+                     (substitute* "gcc/config/i386/gnu.h"
+                       (("/lib/ld\\.so")
+                        (search-input-file
+                          inputs #$(glibc-dynamic-linker matching-system))))
                      (substitute* '("gcc/config/alpha/linux-elf.h"
                                     "gcc/config/arm/linux-elf.h"
                                     "gcc/config/i386/linux.h"