summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-23 00:03:34 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-23 00:06:37 +0200
commit21e583def33ecf9e9bae3a18df875cd3380e14ec (patch)
treeb1c3c61ff6a1cf0390cfcea3045e41eaec93fe85 /gnu/packages/gcc.scm
parent669b8639a229eee2493bc425d124340d6424d86d (diff)
downloadguix-21e583def33ecf9e9bae3a18df875cd3380e14ec.tar.gz
gnu: gcc: Add a RUNPATH to libstdc++.so so that it finds libgcc_s.so.
Fixes <http://bugs.gnu.org/20358>.
Reported by 宋文武 <iyzsong@gmail.com>.

* gnu/packages/gcc.scm (gcc-4.7)[arguments]: Add 'substitute*' form for
  "libstdc++-v3/src/Makefile.in".
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index cd6fc3b2fd..442ea9874e 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -252,6 +252,13 @@ where the OS part is overloaded to denote a specific ABI---into GCC
                 (("static char const sed_cmd_z\\[\\] =.*;")
                  "static char const sed_cmd_z[] = \"sed\";"))
 
+              ;; Add a RUNPATH to libstdc++.so so that it finds libgcc_s.
+              ;; See <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=32354>
+              ;; and <http://bugs.gnu.org/20358>.
+              (substitute* "libstdc++-v3/src/Makefile.in"
+                (("^OPT_LDFLAGS = ")
+                 "OPT_LDFLAGS = -Wl,-rpath=$(libdir) "))
+
               ;; Move libstdc++*-gdb.py to the "lib" output to avoid a
               ;; circularity between "out" and "lib".  (Note:
               ;; --with-python-dir is useless because it imposes $(prefix) as