summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-24 22:41:45 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-24 22:51:07 +0200
commite3d0fcbf7e55e8cbe8d0a1c5a24d73f341d7243b (patch)
tree1a9171dcc33194c9aa6b2bcdfcf77a78bca06256 /gnu/packages/gcc.scm
parent868c13c53a9788f8f27e77d8c8f99df14be512ba (diff)
downloadguix-e3d0fcbf7e55e8cbe8d0a1c5a24d73f341d7243b.tar.gz
gnu: Default to GCC 5.
* gnu/packages/patches/gcc-libiberty-printf-decl.patch: New file.
* gnu/packages/gcc.scm (gcc-5)[source]: Use it.
(gcc): Switch to GCC-5.
* gnu/packages/commencement.scm (libstdc++-boot0): New variable.
(gcc-boot0)[inputs]: Add it.
[native-inputs]: Remove.
(gcc-toolchain-4.9): Switch to GCC-4.9.
(gcc-toolchain-5): Switch to GCC-FINAL.
* gnu-system.am (dist_patch_DATA): Add 'gcc-libiberty-printf-decl.patch'.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1c9bd7dad6..8b3c891c52 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -352,14 +352,16 @@ Go.  It also includes runtime support libraries for these languages.")
               (sha256
                (base32
                 "1ny4smkp5bzs3cp8ss7pl6lk8yss0d9m4av1mvdp72r1x695akxq"))
-              (patches (list (search-patch "gcc-5.0-libvtv-runpath.patch")))))
+              (patches (list (search-patch "gcc-5.0-libvtv-runpath.patch")
+                             (search-patch
+                              "gcc-libiberty-printf-decl.patch")))))
 
     ;; GCC 5 ships with .info files, so no need for Texinfo.
     (native-inputs '())))
 
 ;; Note: When changing the default gcc version, update
 ;;       the gcc-toolchain-* definitions accordingly.
-(define-public gcc gcc-4.9)
+(define-public gcc gcc-5)
 
 (define-public (make-libstdc++ gcc)
   "Return a libstdc++ package based on GCC.  The primary use case is when