summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-28 15:03:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-28 15:11:19 +0200
commit587398d2a82e0b5966a6827d36a1f1d115181b11 (patch)
tree19750e69b60a92273db54c1b75c97caaee6ee0c9 /gnu/packages/gcc.scm
parenta7a8337b28535f29d3c64453fadb91c7c5dfc741 (diff)
downloadguix-587398d2a82e0b5966a6827d36a1f1d115181b11.tar.gz
gnu: custom-gcc: Ensure #:modules are not overridden by the inherited GCC.
This fixes a regression introduced in 56c833ea287f8f6d3c72f8bddc314960c0164d64
where the #:modules argument became ineffective.  Reported by Efraim Flashner
in <https://lists.gnu.org/archive/html/guix-devel/2020-04/msg00473.html>

* gnu/packages/gcc.scm (custom-gcc)[arguments]: Add #:modules through
SUBSTITUTE-KEYWORD-ARGUMENTS.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index b69f3cf4b3..65664828cf 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -641,12 +641,12 @@ as the 'native-search-paths' field."
     (native-search-paths search-paths)
     (properties (alist-delete 'hidden? (package-properties gcc)))
     (arguments
-     (substitute-keyword-arguments `(#:modules ((guix build gnu-build-system)
-                                                (guix build utils)
-                                                (ice-9 regex)
-                                                (srfi srfi-1)
-                                                (srfi srfi-26))
-                                               ,@(package-arguments gcc))
+     (substitute-keyword-arguments (package-arguments gcc)
+       ((#:modules modules %gnu-build-system-modules)
+        `(,@modules
+          (srfi srfi-1)
+          (srfi srfi-26)
+          (ice-9 regex)))
        ((#:configure-flags flags)
         `(cons (string-append "--enable-languages="
                               ,(string-join languages ","))