summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-03-16 18:02:49 -0400
committerMark H Weaver <mhw@netris.org>2016-03-16 18:06:52 -0400
commitce362de86ee79757a98a1438c815fd79a50129a5 (patch)
tree9be327c21726057427173ca268c4f3128dd2119b /gnu/packages/gcc.scm
parent092dd6541fc75ed19ebbb1f9d8e6f32a88cb3445 (diff)
downloadguix-ce362de86ee79757a98a1438c815fd79a50129a5.tar.gz
gnu: Fix definitions of gcc-toolchain-4.8 and gcc-toolchain-4.9.
* gnu/packages/commencement.scm (gcc-toolchain-4.8): Use gcc-4.8,
not gcc-final.
(gcc-toolchain-4.9): Use gcc-final, not gcc-4.9.
* gnu/packages/gcc.scm (gcc): Add reminder comment for the future.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 73c6d488fb..1df5150ab3 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -354,6 +354,8 @@ Go.  It also includes runtime support libraries for these languages.")
                 "1ny4smkp5bzs3cp8ss7pl6lk8yss0d9m4av1mvdp72r1x695akxq"))
               (patches (list (search-patch "gcc-5.0-libvtv-runpath.patch")))))))
 
+;; Note: When changing the default gcc version, update
+;;       the gcc-toolchain-* definitions accordingly.
 (define-public gcc gcc-4.9)
 
 (define-public (make-libstdc++ gcc)