summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-03-06 22:45:47 +0100
committerAndreas Enge <andreas@enge.fr>2015-03-07 10:45:47 +0100
commited2b1c4f5583ebe850bedc0b275b03bdab7c9a84 (patch)
treeef17b6155d4916f0bfb9b481b44128d91f44c4af /gnu/packages/gcc.scm
parente2808a4ac678daf8aafe73406f46afd9937913c7 (diff)
downloadguix-ed2b1c4f5583ebe850bedc0b275b03bdab7c9a84.tar.gz
gnu: gcj: Move javac.in from a file in the distribution to an origin.
* gnu/packages/javac.in: Delete file.
* gnu-system.am (MISC_DISTRO_FILES): Delete.
* gnu/packages/gcc.scm (javac.in): New variable.
  (gcj-4.8): Use it as an input.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index ce37cb92cb..1acc4d5ded 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -339,14 +340,21 @@ Go.  It also includes runtime support libraries for these languages.")
               ;; a cyclic dependency.  <http://debbugs.gnu.org/18101>
               #:separate-lib-output? #f))
 
+(define javac.in
+  (origin
+    (method url-fetch)
+    (uri (string-append "http://sources.gentoo.org/cgi-bin/viewvc.cgi/"
+                        "gentoo-x86/dev-java/gcj-jdk/files/javac.in"))
+    (sha256 (base32
+              "1c3dk4z5yfj6ic2fn3lyxs27n6pmn2wy9k0r1s17lnkf1bzkrciv"))))
+
 (define-public gcj-4.8
   (package (inherit gcc-4.8)
     (name "gcj")
     (inputs
      `(("fastjar" ,fastjar)
        ("perl" ,perl)
-       ("javac.in" ,(search-path %load-path
-                                 "gnu/packages/javac.in"))
+       ("javac.in" ,javac.in)
        ("ecj-bootstrap" ,ecj-bootstrap-4.8)
        ,@(package-inputs gcc-4.8)))
     ;; Suppress the separate "lib" output, because otherwise the