summary refs log tree commit diff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-27 01:21:27 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-27 16:49:58 +0100
commitd5d7d26df7c424a9cffee27f1210b59ef8682d5c (patch)
treed79c9275294734afb55091194788c5b9938373e6 /gnu/packages/gd.scm
parent2504fd3794e9a6fa6fba0fbce4bec2e97652154b (diff)
downloadguix-d5d7d26df7c424a9cffee27f1210b59ef8682d5c.tar.gz
gnu: perl-gd: Update to 2.68.
* gnu/packages/gd.scm (perl-gd): Update to 2.68.
[source]: Remove obsolete patch.
[native-inputs]: Remove perl-module-build.
[inputs]: Use canonical package names and order alphabetically.
[arguments]: Replace #:module-build-flags with fewer #:make-maker-flags,
enable #:tests?, and remove ‘clear-autogenerated-files’ phase.
* gnu/packages/patches/perl-gd-options-passthrough-and-fontconfig.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm43
1 files changed, 13 insertions, 30 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 3b1def55e1..c815cdd7ea 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -93,45 +94,27 @@ most common applications of GD involve website development.")
 (define-public perl-gd
   (package
     (name "perl-gd")
-    (version "2.56")
+    (version "2.68")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://cpan/authors/id/L/LD/LDS/"
+       (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/"
                            "GD-" version ".tar.gz"))
        (sha256
         (base32
-         "1ya8f9hpiax8j29vwaiwlvvgah0vkyvpzva28r8231nyk0f3s40z"))
-       (patches (search-patches
-                 "perl-gd-options-passthrough-and-fontconfig.patch"))))
+         "0p2ya641nl5cvcqgw829xgabh835qijfd6vq2ba12862946xx8va"))))
     (build-system perl-build-system)
-    (native-inputs
-     `(("perl-module-build" ,perl-module-build))) ;needs Module::Build >= 0.42
     (inputs
-     `(("gd" ,gd)
-       ("zlib" ,zlib)
-       ("png" ,libpng)
-       ("ft" ,freetype)
-       ("jpeg" ,libjpeg)
-       ("fontconfig" ,fontconfig)))
+     `(("fontconfig" ,fontconfig)
+       ("freetype" ,freetype)
+       ("gd" ,gd)
+       ("libpng" ,libpng)
+       ("libjpeg" ,libjpeg)
+       ("zlib" ,zlib)))
     (arguments
-     ;; We must use Build.PL for building because Makefile.PL fails to build
-     ;; the XS source.
-     `(#:module-build-flags (map (lambda (i)
-                                   (string-append "--lib_" i "_path="
-                                                  (assoc-ref %build-inputs i)))
-                                 '("zlib" "png" "ft" "jpeg" "fontconfig"))
-       #:tests? #f ;; Failed 1/2 test programs. 1/12 subtests failed.
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'configure 'clear-autogenerated-files
-           (lambda _
-             ;; This file is autogenerated by its .PLS script at build
-             ;; time, but file creation fails because that file already
-             ;; exists in the distribution with non-writable
-             ;; permissions, so delete it first.
-             (delete-file "bdf_scripts/bdf2gdfont.pl")
-             #t)))))
+     `(#:make-maker-flags
+       (list (string-append "--lib_jpeg_path="
+                            (assoc-ref %build-inputs "libjpeg")))))
     (home-page "http://search.cpan.org/dist/GD")
     (synopsis "Perl interface to the GD graphics library")
     (description "GD.pm is an autoloadable interface module for libgd, a