summary refs log tree commit diff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-23 19:32:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-23 20:44:35 +0100
commitdb91596a78cf463056b7304b4fc9e2b19ba042fb (patch)
tree9ac06b100035c629aa305c4671d8ac5169acd2b9 /gnu/packages/gd.scm
parent9b070277f9cb1512787fc6eb10ecf87102508d86 (diff)
downloadguix-db91596a78cf463056b7304b4fc9e2b19ba042fb.tar.gz
gnu: gd: Incorporate grafted changes.
* gnu/packages/gd.scm (gd)[replacement]: Remove.
[source](patches): Add gd-CVE-2019-6977.patch and gd-CVE-2019-6978.patch.
(gd/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index c08c1f6758..2012a38e26 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -39,7 +39,6 @@
 (define-public gd
   (package
     (name "gd")
-    (replacement gd/fixed)
     ;; Note: With libgd.org now pointing to github.com, genuine old
     ;; tarballs are no longer available.  Notably, versions 2.0.x are
     ;; missing.
@@ -55,6 +54,8 @@
 
              (patches (search-patches "gd-CVE-2018-5711.patch"
                                       "gd-CVE-2018-1000222.patch"
+                                      "gd-CVE-2019-6977.patch"
+                                      "gd-CVE-2019-6978.patch"
                                       "gd-fix-tests-on-i686.patch"
                                       "gd-freetype-test-failure.patch"))))
     (build-system gnu-build-system)
@@ -95,16 +96,6 @@ most common applications of GD involve website development.")
                            "See COPYING file in the distribution."))
     (properties '((cpe-name . "libgd")))))
 
-(define-public gd/fixed
-  (hidden-package
-    (package
-      (inherit gd)
-      (source (origin
-                (inherit (package-source gd))
-                (patches (append (origin-patches (package-source gd))
-                                 (search-patches "gd-CVE-2019-6977.patch"
-                                                 "gd-CVE-2019-6978.patch"))))))))
-
 (define-public perl-gd
   (package
     (name "perl-gd")