summary refs log tree commit diff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-20 19:06:38 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-20 19:06:38 +0200
commitb093be236efa913748855879094e38cd983c7f00 (patch)
tree9da0f6f3ec0b5cf57d4aa7a63a480fd8806d05f8 /gnu/packages/gd.scm
parent171bcdf7ba1425072529bacb712792b2a6302544 (diff)
downloadguix-b093be236efa913748855879094e38cd983c7f00.tar.gz
gnu: gd: Remove graft for 2.2.5.
* gnu/packages/gd.scm (gd): Update to 2.2.5.
[source]: Remove obsolete patches.
[replacement]: Remove field.
(gd-2.2.5): Remove variable.
* gnu/packages/patches/gd-fix-gd2-read-test.patch,
gnu/packages/patches/gd-php-73968-Fix-109-XBM-reading.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove patches.
* gnu/packages/php.scm (php)[inputs]: Replace GD-2.2.5 with GD.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm27
1 files changed, 4 insertions, 23 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 169f040ee4..f9864d7784 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -38,11 +38,10 @@
 (define-public gd
   (package
     (name "gd")
-    (replacement gd-2.2.5)
     ;; Note: With libgd.org now pointing to github.com, genuine old
     ;; tarballs are no longer available.  Notably, versions 2.0.x are
     ;; missing.
-    (version "2.2.4")
+    (version "2.2.5")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -50,11 +49,9 @@
                    version "/libgd-" version ".tar.xz"))
              (sha256
               (base32
-               "1rp4v7n1dq38b92kl7gkvpvqqkw7nvdfnz6d5kip5klkxfki6zqk"))
-             (patches (search-patches "gd-fix-gd2-read-test.patch"
-                                      "gd-fix-tests-on-i686.patch"
-                                      "gd-freetype-test-failure.patch"
-                                      "gd-php-73968-Fix-109-XBM-reading.patch"))))
+               "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
+             (patches (search-patches "gd-fix-tests-on-i686.patch"
+                                      "gd-freetype-test-failure.patch"))))
     (build-system gnu-build-system)
     (arguments
       ;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
@@ -93,22 +90,6 @@ most common applications of GD involve website development.")
                            "See COPYING file in the distribution."))
     (properties '((cpe-name . "libgd")))))
 
-;; For CVE-2017-6362 and CVE-2017-7890.
-(define-public gd-2.2.5
-  (package
-    (inherit gd)
-    (version "2.2.5")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/libgd/libgd/releases/download/gd-"
-                    version "/libgd-" version ".tar.xz"))
-              (patches (search-patches "gd-fix-tests-on-i686.patch"
-                                       "gd-freetype-test-failure.patch"))
-              (sha256
-               (base32
-                "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))))))
-
 (define-public perl-gd
   (package
     (name "perl-gd")